Arms cyber

Azure outage
Resolved·Full outage

Accessibility to our services has been restored to normal levels. While the underlying Azure outage is not fully resolved, it has stabilized sufficiently.

Wed, Oct 29, 2025, 10:28 PM
(1 week ago)
·
Affected components
Web Application
API
Updates

Resolved

Accessibility to our services has been restored to normal levels. While the underlying Azure outage is not fully resolved, it has stabilized sufficiently.

Wed, Oct 29, 2025, 10:28 PM

Monitoring

While many of Azure's services have been restored network infrastructure is still suffering from a major outage and impacting our applications availability.

Wed, Oct 29, 2025, 05:54 PM(4 hours earlier)

Monitoring

We are starting to see waves of Azure services become healthy with the console app now being semi restored.

Wed, Oct 29, 2025, 05:35 PM(19 minutes earlier)

Monitoring

We are aware of and following a major Azure outage currently disrupting our services

Wed, Oct 29, 2025, 04:43 PM(51 minutes earlier)
Powered by